Important Notice
Toward the end of October, PurelyHR.com will no longer support TLS 1.0 over HTTPS. This means older browsers that do not support TLS 1.1 or 1.2 will no longer work after this date. This change is mandated by the PCI Security Council and affects all service providers processing or transmitting credit card data. For more information, and to see if you'll be affected by this change, please visit our TLS Upgrade blog post.

We apologize for any inconvenience. If you have any questions in regards to this upcoming change, please email us at support@purelyhr.com

Sincerely,
PurelyHR Team
Powered by
PurelyHR